epik SSL Not Working on Landers?

Visit nameliquidate.com
ebook DomainGraduate.com
This is a discussion about the domain name registrar/company Epik.

accurate

Level 7
Joined
Sep 28, 2012
Messages
961
Reaction score
378
Feedback: 0 / 0 / 0
Anyone having issues with SSL certs not working on Epik landers?

I just changed a bunch back to these landers and a bunch are throwing errors.

I don't have time to check every single one.
 
Visit Epik

amplify

DNForum Moderator
DNF Staff
Joined
Sep 15, 2009
Messages
3,407
Reaction score
1,142
Feedback: 68 / 0 / 0
Any ideas?
Reported it to Epik staff as I can confirm mine is insecure as well.

Also, you can tag just @Epik on DNForum. This will send an alert to all Epik staff that are on the forum in the capacity to deal with issues that arise and affect Epik. :)

(Still determining who all will be in this group.)
 

accurate

Level 7
Joined
Sep 28, 2012
Messages
961
Reaction score
378
Feedback: 0 / 0 / 0
Thanks @amplify for help.

Reported it to Epik staff as I can confirm mine is insecure as well.

Also, you can tag just @Epik on DNForum. This will send an alert to all Epik staff that are on the forum in the capacity to deal with issues that arise and affect Epik. :)

(Still determining who all will be in this group.)
 

amplify

DNForum Moderator
DNF Staff
Joined
Sep 15, 2009
Messages
3,407
Reaction score
1,142
Feedback: 68 / 0 / 0
I had a similar problem with about 10 of my domains. I changed the nameservers on them to Parking Crew in order to enter them in the ROTD auction. It turns out that the certs expired when I did that. So when I changed back to ns3/4.epik.com, it was giving me insecure errors and invalid certs. If you did something similar, you might just want to repark them. If that doesn't help, get in contact with Rob about specific domains if you do not want to publicly list them here.
 

accurate

Level 7
Joined
Sep 28, 2012
Messages
961
Reaction score
378
Feedback: 0 / 0 / 0
Something similar happened but I really don't have time to deal with this @amplify.

I hope @Epik can comment.

I had a similar problem with about 10 of my domains. I changed the nameservers on them to Parking Crew in order to enter them in the ROTD auction. It turns out that the certs expired when I did that. So when I changed back to ns3/4.epik.com, it was giving me insecure errors and invalid certs. If you did something similar, you might just want to repark them. If that doesn't help, get in contact with Rob about specific domains if you do not want to publicly list them here.
 

JLJ

Level 1
Epik Staff
Joined
Feb 25, 2021
Messages
8
Reaction score
13
Feedback: 0 / 0 / 0
Hey folks!

Just having the Epik Name Servers won't be sufficient to get the SSL on your landers by default. You'd need to deploy the Premium Parking on the domains, which will issue the SSL for the landing page.

Can I confirm that is what's done here? So if you added NS3.EPIK.COM and NS4.EPIK.COM, you'd still have to select the domains in your Epik Dashboard and click Build -> Park This Domain -> Epik Premium Parking.

We're doing a check of the SSL status and investigating the new domains getting in the system, so we should have more information soon if this is a widespread problem.
 

accurate

Level 7
Joined
Sep 28, 2012
Messages
961
Reaction score
378
Feedback: 0 / 0 / 0
Hey folks!

Just having the Epik Name Servers won't be sufficient to get the SSL on your landers by default. You'd need to deploy the Premium Parking on the domains, which will issue the SSL for the landing page.

Can I confirm that is what's done here? So if you added NS3.EPIK.COM and NS4.EPIK.COM, you'd still have to select the domains in your Epik Dashboard and click Build -> Park This Domain -> Epik Premium Parking.

We're doing a check of the SSL status and investigating the new domains getting in the system, so we should have more information soon if this is a widespread problem.

SSL should be added automatically. @Epik
 
Visit nameinvestors.com
Top Bottom